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Welcome to the Live Recording Guide for Avid VENUE | S6L systems. 

This guide shows you how to integrate Pro Tools recording and playback with your S6L system and includes the following topics: 

ÅWhat is Virtual Soundcheck, VENUE Link, and Pro Tools AVB.

ÅHow to set up Pro Tools AVB, VENUE Link, and Pro Tools Sessions to record and play back up to 128 channels of audio with VENUE.

ÅHow to perform a complete Virtual Soundcheck. 

ÅHow to route and record Mains, audience mics, and submix outputs. 

ÅHow to integrate Pro Tools tracks into your performances. 

ÅHow to toggle individual channels between Stage and Pro Tools input, and how to use Input mode

ÅHow to control the Pro Tools Transport from S6L, how to link Pro Tools Markers to S6L snapshots, and more

ÅHow to record/playback via MADI using MADI-192 MADI Option Cards. 

ÅHow to use Stage 64 MADI outputs to record to a MADI-compatible device.

In this guide, instructions for VENUE | S6L and S6L systems are generally applicable to S3L-X systems also. Note that S3L-X systems support 
Stage 16 I/O units only. 

Overview of VENUE Recording and Playback Features 

S6L S3L-X/S3L Record Playback Virtual Soundcheck VENUE Link

Pro Tools AVB V V V V V V

MADI-192 MADI Option Cards V V V V V

Stage 64/32 MADI Out V V



To get the most out of this guide, take a moment to familiarize yourself with the following terms and concepts. 

Recording Outputs
Ethernet AVB or MADI-192 MADI Option Card audio connections carry the following types of output signals from the S6L system to Pro Tools for 
recording:

5ƛǊŜŎǘ 5ƛƎƛǘŀƭ {Ǉƭƛǘǎ όtǊƻ ¢ƻƻƭǎ ά!ǳǘƻ-tŀǘŎƘέύ
Stage inputs assigned to S6L system input channels are automatically sent to Pro Tools as unprocessed direct digital splits. A Pro Tools session 
recorded using direct digital splits are an essential part of the Virtual Soundcheck workflow. 

Assignable Pro Tools Outputs
For any system input channels not assigned Stage inputs as their sources, assignable recording outputs are available, up to the maximum number of 
available Pro Tools I/O channels. Assignable outputs can be used to send the Direct Outs of S6L system I/O channels,  the Main L/R mix and other 
submixesfrom sources such as Matrix and Groups, and audience micsto Pro Tools. Assignable outputs also let you record pre-fader/post-insert or 
post-fader S6L signals. Note, however, that recording pre-fader/post-insert of post-fader signals disqualifies the recordings ofthese outputs for use 
ƛƴ ±ƛǊǘǳŀƭ {ƻǳƴŘŎƘŜŎƪΣ ǿƘƛŎƘ ǊŜǉǳƛǊŜǎ ŘƛǊŜŎǘ άǎǇƭƛǘǎέ ƻŦ ŎƘŀƴƴŜƭǎ ǿƛǘƘ ƴƻ {с[ ǇǊƻŎŜǎǎƛƴƎ ŀǇǇƭƛŜŘ ƻǘƘŜǊ ǘƘŀƴ ƛƴǇǳǘ ƎŀƛƴΦ 

Playback Inputs
Ethernet AVB or MADI-192 MADI Option Card audio connections carry the following types of input signals to the S6L system from Pro Tools for 
playback:

Virtual Soundcheck Inputs
Any S6L input channel with a Stage input as its source is automatically assigned a corresponding Pro Tools Virtual Soundcheckinput. The source for 
that S6L system input channel can then be toggled between its assigned Stage input and its corresponding Virtual Soundcheck input, either globally 
or individually. When Virtual Soundcheck inputs are active, you can make adjustments to your mix using pre-recorded Pro Tools tracks derived from 
direct digital splits of your Stage inputs. All changes carry over when you switch back to live Stage inputs. You can also choose to apply any Input 
Gain changes made to input channels when switching back to Stage inputs. For more information, see What is Virtual Soundcheck?

Assignable Pro Tools Inputs
For any system input channels not assigned Stage inputs as their sources, assignable Pro Tools inputs are available, up to the maximum number of 
available Pro Tools I/O channels. Assignable inputs can be used to monitor your Pro Tools recording on your S6L system, or toincorporate pre-
recorded audio tracks into your live mix. To learn more, see Using Assignable Inputs. 

Pro Tools Input Mode
In Pro Tools Input mode, audio from Pro Tools via AVB or MADI (if any MADI-192 MADI Option cards are installed) is the main source of audio for your 
S6L system. Stage inputs on your S6L system are replaced with inputs from Pro Tools. Unlike Virtual Soundcheck mode, changes made to Input Gain 
settings while operating in Pro Tools Input mode cannot be applied when switching back to Stage inputs. To learn more, see Using Input Mode. 

VENUE Link
VENUE Link is a communication link between your S6L and Pro Tools systems. Using this link, you can transfer data between systems and control 
Pro Tools from the S6L control surface.

VENUE Link is an integral part of the Virtual Soundcheck workflow. Use features such as Create Session from VENUE to properly and quickly create a 
Virtual Soundcheck-compatible  Pro Tools session.  For more information, see What is VENUE Link? 



When using Pro Tools with S6L via Pro Tools AVB and VENUE Link you get true Virtual SoundCheckfunctionality.

Here is an overview of the complete Virtual Soundcheckworkflow:  

Record a Show
ÅAfter enabling VENUE Link, create a Pro Tools session with 

tracks that are automatically created, named, and routed 
based on your VENUE channels. 
ÅRecord all live stage inputs directly to Pro Tools. The pick-

off point is post A-to-D (analog-to-digital) conversion but 
before all VENUE channel processing, making the 
recorded material the most accurate way to recreate your 
mix during Virtual Soundcheck. While recording, recalling 
a sequential VENUE snapshot can create a Pro Tools 
Marker in the Pro Tools timeline. 

Perform a Virtual Soundcheck
ÅPlay back the previously recorded Pro Tools tracks. Tracks 

play through their matching VENUE Input channels.  
ÅDuring playback adjust levels, program and update 

snapshots, experiment with different plug-ins, and more. 
To jump to specific songs or scenes, recall snapshots 
linked to Pro Tools Markers. 
ÅWhile in Virtual Soundcheck mode all adjustments are 

applied instantly to the currently loaded Show file.Be 
sure and Overwrite the currently loaded Show file or 
create a new Show file to retain those settings. 

Apply and Update
ÅSwitch the VENUE system back to Stage inputs mode.
ÅLŦ ȅƻǳΩǾŜ ƳŀŘŜ ŎƘŀƴƎŜǎ ǘƻ ƛƴǇǳǘ Ǝŀƛƴ ǿƘƛƭŜ ƛƴ ǇƭŀȅōŀŎƪΣ ȅƻǳΩƭƭ 

be given the option to apply or ignore those changes to the 
Stage Rack pre-amps. For the Virtual Soundcheck work flow 
ȅƻǳΩƭƭ Ƴƻǎǘ ƭƛƪŜƭȅ ŎƘƻƻǎŜ ǘƻ ŀǇǇƭȅ ǘƘƻǎŜ ŎƘŀƴƎŜǎΦ

Repeat
ÅRecord the next show. 
ÅUse those new tracks at the next soundcheck. 
ÅApply additional adjustments to further refine your live mix.
ÅSimultaneously compile a catalog of live recordings.  

Pro Tools

VENUE S6L

όbƻǘŜΥ ¸ƻǳ Ŏŀƴ ŀƭǎƻ ǊŜŎƻǊŘ [κw aŀƛƴǎΣ άǎǘŜƳǎέ όsubmixesof any combination of channels), or audience micsas explained in Assignable I/O).



VENUE Linkis a communication protocol that uses the same Ethernet connection to the Pro Tools computer as Pro Tools AVB. 

Essential to the complete Virtual Soundcheckworkflow, VENUE Link lets you take advantage of the following capabilities: 

ÅCreate Session from VENUEQuickly create Pro Tools sessions that automatically populate and name tracks based on your VENUE 
channels, and automatically assign Pro Tools track inputs and outputs to correspond with VENUE I/O 1-for-1.

ÅTransport ControlVENUE Link lets you control the Pro Tools Transport directly from the S6L control surface. 

VENUE Patchbay

Pro Tools Session
created from VENUE

VENUE Input channels generate and name Pro Tools tracks

VENUE patching defines Pro Tools track I/O

With VENUE Link enabled you can also create and link Pro Tools Makers (memory locations) with VENUE Snapshots.  

ÅAssignable Pro Tools IO ¢ƻ ŀƭǎƻ ǊŜŎƻǊŘ [κw aŀƛƴǎΣ άǎǘŜƳǎέ όsubmixesof any combination of channels), or audience micsyou can use Assignable I/O. 

For a more detailed explanation and specific examples, see About Track Assignments in Pro Tools. 



VENUE | S6L systems provide direct connection to a computer runningPro Tools software via AVB Ethernet. 
The Ethernet AVB connection between your S6L system and Pro Tools provides up to 128 channels of 
simultaneous Pro Tools I/O.No additional audio hardware is required to connect your S6L system to Pro Tools.

Requirements: 
ÅThe Pro Tools license mustbe present on the Pro Tools iLok. 
ÅBeginning with Pro Tools 2018.10, the functionality provided by the Live Sound Production Toolkit is included in Pro Tools and is  

automatically enabled whenever the Pro Tools Playback Engine is set to E6L. For maximum compatibility, transfer the Live Sound 
Production Toolkitto your ProTools iLokto enable 64- and 128-channel Pro Tools AVB with Pro Tools 2018.7 or earlier. (If you are renting 
a system, be sure the Pro Tools iLokwith both of these licenses is also provided). Without the LiveSoundProduction Toolkit license, 
Pro Tools recording is limited to 32 tracks. 
Å128-channel AVB requires 2x AVB-192 Network Cards in the E6L Engine. 
ÅPro Tools AVB requires an AVB-compatible Mac. Special system requirements for the Pro Tools computer may apply depending on the 

number of channels required. For the latest compatibility information and system requirements, visit this article on our Knowledge Base:    
What are the system requirements for Pro Tools with S6L?

I want to do this, how do I start?  
ÅSee Pro Tools AVB Connections and Settings, then configure VENUE Link.

This single Ethernet connection lets you record multi-track Pro Tools sessions of performances 
using a variety of S6L system audio sources, including digital splits of your Stage inputs, channel 
Direct Outputs, and bus outputs. 

Beginning with VENUE software version 6.1 up to two compatible Pro Tools computers can be 
connected to S6L simultaneously for redundant 128-channel recording.  

You can also play back multi-track audio from Pro Tools through your S6L system to integrate 
pre-recorded tracks with your live mix, or to monitor your Pro Tools recording on your S6L 
system. When VENUE Link is enabled, the same connection also lets you control the Pro Tools 
Transport from the S6L control surface. 

By combining recording and playback features, you can perform a true Virtual Soundcheck. 

What is an iLok? An iLokis a USB device that can hold hundreds of authorizations for all of your iLok-enabled software. When you activate Avid software, licenses 
are deposited in your iLokaccount at iLok.com. Use the free IlokLicense Manager application to transfer your licenses from iLok.com to the appropriate iLok. 

http://avid.force.com/pkb/articles/compatibility/What-are-the-system-requirements-for-Pro-Tools-with-S6L
https://www.ilok.com/


Pro Tools AVB Redundant Record
Beginning with VENUE software version 6.1 you can perform redundant recording of 128 channels via Pro Tools AVB to two qualified Pro Tools 
computers. Up to two (2) compatible Pro Tools computers can be connected to a single VENUE S6L system by connecting them to Network 
ports Cand Don the S6L control surface.  

I/O Sharing Configurations
When two S6L systems are configured for I/O Sharing, up to two Pro Tools computers, total, can be connected. You can connect onePro Tools 
computer to each system (use Network port C on both S6L control surfaces), or connect both computers to Network ports Cand Don either 
single S6L system for redundant recording. 
Å When one computer is connected to each separate S6L control surface, either computer can record or play back up to 128 channels. 
Å When both computers are connected to the same S6L control surface, the same record/playback rules apply as when two computers are 

connected to a single system. 

Redundant Recording 

On both Pro Tools systems, enable VENUE Link and use Create Session from VENUE 
to be able to record your performance to both Pro Tools systems simultaneously 
(fully redundant recording of up to 128 tracks) for Virtual Soundcheck and archiving. 
By enabling VENUE Link on both systems, both Pro Tools systems respond as one to 
Transport commands from S6L. 

Virtual Soundcheck 

When you switch the S6L system Input Source to Pro Tools to perform a Virtual 
Soundcheck, playback will be available from the Pro Tools computer that was 
connected to the E6L engine last in AMS. When VENUE Link is enabled on both 
Pro Tools systems they will both play back and cue in response to Transport 
commands from S6L, but audio from the first-connected Pro Tools system will not be 
available (only audio from the last-connected ProTools system is recognized by S6L). 

Simultaneous Record/Playback 

If you need to simultaneously record to and play back from Pro Tools to integrate 
backing tracks, count-offs or other material, use a single Pro Tools system connected 
to S6L Network port C, only. 

Connections for Pro Tools AVB redundant recording

For additional details and information see Working with Pro Tools in Shared I/O Configurations. 



This guide assumes that you have already done each of the following: 
ÅSet up your VENUE system and confirmed successful installation of the latest VENUE software
ÅFor Pro Tools AVB ςMake sure you have already installed Pro Tools software on an AVB-compatible Mac and confirmed that it is operating correctly (for 

the latest compatibility information, see What Are the System Requirements for Pro Tools with S6L?)

System Requirements and Compatibility  

If you have not completed any of the above tasks, refer to the VENUE S6L Installation Guide.pdf for S6L and Pro Tools installation instructions You can download these 
and all other VENUE documentation, including the the VENUE S6L Handbook.pdf, from your Avid account.

Example iLokaccount shown in iLokLicense Manager  

Visit iLok.comto sign-in to your iLokŀŎŎƻǳƴǘΣ ƻǊ ŎǊŜŀǘŜ ƻƴŜ ƛŦ ƴŜŎŜǎǎŀǊȅ όƛǘΩǎ ŦǊŜŜύΦ 5ƻǿƴƭƻŀŘ  ŀƴŘ ƛƴǎǘŀƭƭ iLokLicense Manageron a Mac or PC, then transfer 
the following licenses to the correct iLokas shown below: 

VENUE Plug-in Licenses
The S6L Plug-In Bundle and other 
VENUE plug-in licenses must be 
transferred to your VENUEiLok(the 
licenses must be present on an iLok
connected to your VENUE system). 

VENUE iLok

Pro Tools iLok

iLokRequirements
ÅTransfer the Pro Toolslicense and  LiveSoundProduction Toolkit to your Pro Tools iLok, and make sure that your Pro Tools iLokis connected to your 

Pro Tools computer. Without the LiveSoundProduction Toolkit (or Pro Tools 2018.10 or later) recording via Pro Tools AVB is limited to 32 tracks. 

ÅFor Pro Tools AVB and VENUE Link ςMake sure you have acquired an Ethernet cable (Cat5-e or better) to connect the S6L system tothe Pro Tools computer
ÅFor Pro Tools recording using MADI, make sure you have installed Pro Tools software on a compatible  Mac or Windows computer that is capable of recording 

and/or playing back the desired number of tracks via MADI

Important! Do the following to optimize your Mac for AVB recording and playback:
ÅDisable Wi-Fi, Airport, and Bluetooth, and turn off Internet Sharing
ÅTurn off Energy Saving, and disable Notification Center!

Pro Tools License
Must be transferred to your Pro Tools iLok. If you are 
using Pro Tools 2018.7 or earlier, the LiveSound
Production Toolkit license must also be present on the 
iLokconnected to your Pro Tools computer to enable 
recording of more than 32 tracks).

About the Live Sound Production Toolkit   Beginning with Pro Tools 2018.10, the functionality provided by the Live Sound Production Toolkit is included in Pro Tools and 
is automatically enabled when the Pro Tools Playback Engine is set to E6L. For maximum compatibility, transfer the Live Sound Production Toolkitto your ProTools iLok
to enable 64- and 128-channel Pro Tools AVB with Pro Tools 2018.7 or earlier. (If you are renting a system, be sure the Pro Tools iLokwith both of these licenses is also 
provided). Without the LiveSoundProduction Toolkit license, recording to Pro Tools 2018.7 is limited to 32 tracks. 

http://avid.force.com/pkb/articles/en_US/Compatibility/What-are-the-system-requirements-for-Pro-Tools-with-S6L
https://my.avid.com/account/orientation?returnUrl=https://my.avid.com/account
https://www.ilok.com/
http://avid.force.com/pkb/articles/Compatibility/en436391?retURL=/pkb/articles/en_US/Compatibility/en353265&popup=true
http://avid.force.com/pkb/articles/compatibility/en353265


Connecting and Configuring Systems

Follow these links for Pro Tools AVBthen proceed to VENUE Link. 

VENUE Link

Pro Tools AVB

S6L MADI-192 MADI Option Cards S6L Stage 64 MADI Out

For MADI recording and playback, begin by following these links for connection diagrams and configuration instructions.  



Before you can record and playback with Pro Tools via AVB, do each of the following: 
ÅMake sure you have met all the System Requirementsdescribed earlier, including Mac optimizations and setting up your iLoks(very important!)
ÅConnect S6L to Pro Tools (connect AVB), configure the Pro Tools computer (enable AVB), configure Pro Tools (Setup > Playback Engine), then 

enable VENUE Link. 

Connect S6L to Pro Tools

1. To connect a single Pro Tools computer, connect an Ethernet cable 
from Network Port Con the S6L control surface to an available 
Ethernet port on the Pro Tools computer. 

2. If your computer only has Thunderbolt ports: 

ÅThunderbolt 2Use a Thunderbolt-to-Gigabit Ethernet adapter

ÅThunderbolt 3 (USB-C)Two adapters are required at the time of this writing, a USB-C to Thunderbolt 2 adapter, and a Thunderbolt (2)-
to-Gigabit Ethernet adapter. (Be aware that not all USB-C to Ethernet adapters are AVB-compatible.)

3. Proceed to Configure the Pro Tools Computer. 

Cables Connections
Ethernet 
(Cat5-eor better)

ÅS6L network
ÅPro Tools AVB/VENUE Link

Connections for a single Pro Tools AVB computer

Note: A direct connection between the S6L system and Pro Tools is required. Network equipment such as routers, hubs, and switches 
are not supported for S6L network connections to Pro Tools.!

To connect two Pro Tools computers for redundant recording, connect an 
Ethernet cable from Network Port Cand Don the S6L control surface to 
an available Ethernet port on each Pro Tools computer. 

Connections for two Pro Tools AVB computers

If multiple S6L systems are configured for I/O Sharing, you can connect one Pro Tools system to each S6L or connect up to two 
Pro Tools systems to either single S6L. For more information, see the VENUE S6L Installation Guide.pdf. 



Do all of the following to optimize your Mac(s) for AVB recording and 
playback:
ÅTurn off Internet Sharing (System Preferences > Sharing)

ÅDisable Wi-Fi, Airport, and Bluetooth (System Preferences > Network)

ÅTurn off Energy Saving

ÅDisable Notification Center (System Preferences > Notifications)

Important!

Internet Sharing disabled in System Preferences > Sharing

Make sure you have already installed Pro Tools software on an AVB-compatible Mac and confirmed that it is operating correctly (for the latest 
compatibility information, see What Are the System Requirements for Pro Tools with S6L?). 

For a complete list of optimizations for your Pro Tools computer, visit: 
Pro Tools Computer Optimization

http://avid.force.com/pkb/articles/en_US/Compatibility/What-are-the-system-requirements-for-Pro-Tools-with-S6L
http://avid.force.com/pkb/articles/troubleshooting/en367983


To enable AVB on the Pro Tools computer: 
1. If multiple S6L systems are connected for I/O Sharing, disconnect the 

Ethernet cable between the two E6L engines until after you have enabled 
AVB on the Pro Tools computer(s). For additional recommendations, see 
Working with Pro Tools in Shared I/O Configurations.

2. Make sure your S6L system and Pro Tools computer are powered on. 

3. On the Pro Tools computer, go to Applications > Utilities and launch Audio 
MIDI Setup.
If you have 2x AVB-192 Network Cards installed in your E6L engine and 
your Mac configuration supports 128 channels of AVB, see Enabling 128 
Channel AVB.

4. In Audio MIDI Setup, click the Window menu and choose  
Show Network Device Browser. 
Each currently connected and powered-on E6L appears in the Device list 
ŀǎ ά9с 9ƴƎƛƴŜ xxxxΦέ

5. Click to enable the desired E6L engine. 

(Optional) So that you can differentiate your E6L from any others on the 
network, name your E6L by doing the following:

Enabled E6L

Entering a custom name

6. Repeat for any other Pro Tools computers you plan to use. 

7. Proceed to Configure Pro Tools. 

ÅFrom the Audio MIDI Setup Network Device Browser Devices list, 
select the E6L Engine so it is highlighted.
ÅPress Enter, enter a name, then press Enter again to save the name. 

(On laptops without a dedicated Enter key, press fn+Return.) 

Note: If you are connecting two Pro Tools computers to a single S6L 
system, the first computer to connect to that E6L in AMS will be able 
to record only. The second computer to connect to that E6L in AMS 
will be able to record (redundant), and be the Pro Tools AVB Input 
Source when performing a Virtual Soundcheck. 

Tip: After you have enabled AVB and configured Audio MIDI Setup as described above you will not need to repeat these steps inthe future if using the 
same VENUE system and the same computer(s). You will only need to repeat the above steps if connecting a different VENUE system or computer(s).

Configure the Pro Tools Computer

Important! Make sure you have performed all the Mac optimizations described on the previous page. 



Enable 128 Channel AVB
You can toggle between 128- and 64-channel AVB using Audio MIDI Setup on your Mac. 128-channel AVB requires 2x AVB-192 Network Cards 
in the E6L Engine, and a compatible Mac(currently only Mac Pro computers).

Current Configuration selector in AVB Audio Entity window

To configure AVB for 128- or 64-channels:
1. On your AVB-compatible Mac, launch Audio MIDI Setup and open the Network 

Devices Browser (Command 3).

2. Make sure there is a check next to the E6L; if not, click to enable it.

3. Open the Audio Devices window (Window > Show Audio Devices) and do the 
following: 
ÅSelect the E6L in the column at the far left.
ÅFrom the Options selector (gear icon), choose Configure device. 

4. In the AVB Audio Entity Configuration window, click the Current Configuration 
selector and choose either 64x64 96 kHz or 128x128 96 kHz.

AMS Audio Devices > Configure device

5. Close the AVB Audio Entity Configuration window. 

6. Close AMS.

7. Proceed to Configure Pro Tools.

http://avid.force.com/pkb/articles/compatibility/What-are-the-system-requirements-for-Pro-Tools-with-S6L


Confirm Communication
To confirm S6L-to-Pro Tools communication: 
1. On the external VENUE software screen, go to the Options > Devices page. 

2. In the CONNECTED DEVICES column, an icon representing the Pro Tools computer 
is shown to indicate that the connection to Pro Tools is active. 

Å When only one Pro Tools computer is connected, it appears in the CONNECTED 
column. 

Å When two Pro Tools computers are connected, only the computer that connected 
to the E6L last in AMS appears. This Pro Tools computer can perform recording, and 
will be the Pro Tools source for Virtual Soundcheck playback (the first computer to 
connect to the E6L in AMS can only record). 

3. With communication confirmed, proceed to VENUE Link. 

Configure the Pro Tools Playback Engine
After you have enabled AVB, configure the Pro Tools Playback Engine dialog and then confirm  S6L-to-Pro Tools communication.

E6 Engine selected as the Pro Tools Playback Engine

Pro Tools listed in 
CONNECTED DEVICES

To configure Pro Tools:

1. Launch Pro Tools, and if the Dashboard appears click Cancel.

2. Choose Setup > Playback Engine to open the Playback Engine dialog.

3. From the Playback Engine selector, choose your E6L engine. 

The default name for the E6L is <E6L Engine:AVB> unless you entered a custom name 
for it in the Audio MIDI Setup > Network Devices browser.

Tip: For best performance, use the highest available buffer size (in Setup > Playback 
Engine, choose 2048 (for 96 kHz projects) from the H/W Buffer Size pop-up). 

4. Click OK.






























































